MINIMUM REQUIREMENTS

Here’s what you’ll need
to
use TurboTax

TurboTax is compatible with all common web browsers and operating systems.

Minimum Operating Systems and Browsers

Windows
  • Windows 10.x

    • Firefox 65.x
    • Edge 15
    • Chrome 73.x
    • Opera 58.x
  • Windows 8.1

    • Firefox 65.x
    • Edge 15
    • Chrome 73.x
    • Opera 58.x
  • Windows 8

    • Firefox 65.x
    • Edge 15
    • Chrome 73.x
    • Opera 58.x
  • Windows 7

    • Firefox 65.x
    • Edge 15
    • Chrome 73.x
    • Opera 58.x
Mac
  • Mac OS X 10.15.x (Catalina)

    • Firefox 65.x
    • Edge 15
    • Safari 13.x
    • Chrome 73.x
    • Opera 58.x
  • Mac OS X 10.14.x (Mojave)

    • Firefox 65.x
    • Edge 15
    • Safari 13.x
    • Chrome 73.x
    • Opera 58.x
  • Mac OS X 10.13.x (High Sierra)

    • Firefox 65.x
    • Edge 15
    • Safari 13.x
    • Chrome 73.x
    • Opera 58.x
  • Mac OS X 10.12.x (Sierra)

    • Firefox 65.x
    • Edge 15
    • Safari 12.x
    • Chrome 73.x
    • Opera 58.x
  • Mac OS X 10.11.x (El Capitan)

    • Firefox 65.x
    • Edge 15
    • Safari 11.x
    • Chrome 73.x
    • Opera 58.x
  • Mac OS X 10.10.x (Yosemite)

    • Firefox 65.x
    • Edge 15
    • Safari 10.x
    • Chrome 73.x
    • Opera 58.x
  • Mac OS X 10.9.x (Mavericks)

    • Firefox 65.x
Mobile / Other
  • iOS 11.x

    • Safari
    • Chrome
    • Firefox
  • Android 5.x

    • Chromium default browser
  • Chromebook

    • Chrome